InstallationΒΆ

Instaloader requires Python, at least version 3.5. If you have pip installed, you may install Instaloader using

pip3 install instaloader

Alternatively, to get the most current version of Instaloader from our Git repository:

pip3 install git+https://github.com/Thammus/instaloader

(pass --upgrade to upgrade if Instaloader is already installed)

Instaloader requires requests, which will be installed automatically, if it is not already installed.

Alternative methods for installing Instaloader:

  • If you do not want to use pip, even though it is highly recommended, and prefer to install Instaloader manually, Download the Source, extract the Zip or Tarball and execute instaloader.py from there.
  • On Arch Linux, you may install Instaloader using the Instaloader AUR package.
  • On Gentoo Linux, you may install Instaloader using the Instaloader Ebuild.

Next Section

Download Pictures from Instagram